Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-5317

1st. character from realm value is deleted from endpoint /json/authenticate?realm=myRealm"

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 12.0.0, 13.0.0
    • Fix Version/s: 12.0.1, 13.0.0
    • Component/s: rest
    • Environment:
      OpenAM 12.0.0-RC5 Build 11888 (2014-December-13 12:44)
    • Sprint:
      Sprint 75 - Team Tesla, Sprint 76 - Team Tesla
    • Support Ticket IDs:

      Description

      1st. character from realm value is deleted from endpoint /openam/json/authenticate?realm=myRealm"

      STEPS TO REPRODUCE:
      1.) Create a subrealm
      2.) Try to authenticate via subrealm used REST

      curl --request POST --header "X-OpenAM-Username: bjensen" --header "X-OpenAM-Password: secret12" --header "Content-Type: application/json" --data "{}" "http://perf-openam.internal.forgerock.com:8080/openam/json/authenticate?realm=subrealm"
      

      Observed Result:

      {"code":400,"reason":"Bad Request","message":"Invalid realm, ubrealm"}
      

      Expected Result:

      {"tokenId":"AQIC5...g4MzM1*","successUrl":"/openam/console"}
      

      I tried add 2x first latter and I got expected result.
      /openam/json/authenticate?realm=ssubrealm"

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                quentin.castel Quentin CASTEL [X] (Inactive)
                Reporter:
                richard.hruza Richard Hruza
                QA Assignee:
                Richard Hruza
              • Votes:
                0 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: