Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-5400

Policy Editor: Unable to edit/delete policy whose name ends in a '/' character

    Details

    • Sprint:
      Sprint 77 - Sustaining, Sprint 78 - Sustaining, Sprint 91 - Team Curie
    • Support Ticket IDs:

      Description

      It is not possible to read/edit/delete a policy that ends with a '/' character via the policy editor as calls to the REST backend result in 404 not found errors.

      At some point it looks like the trailing slash on the policy name is being removed. It is still displayed correctly, but calls to the REST endpoint are missing the trailing slash character completely. I have not found the point where this occurs, but it is already missing by the time the PolicyDelegate.js is called.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                esergueeva esergueeva [X] (Inactive)
                Reporter:
                neil.madden Neil Madden
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 20h
                  20h
                  Remaining:
                  Remaining Estimate - 20h
                  20h
                  Logged:
                  Time Spent - Not Specified
                  Not Specified