Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-5488

Upgrade fails from OpenAM 11 to OpenAM 12 with NPE from OAuth2 client profile

    Details

    • Sprint:
      Sprint 77 - Sustaining
    • Support Ticket IDs:

      Description

      When upgrading from OpenAM 11.0.2 to OpenAM 12, a NPE occurs while looking for upgradable Oauth2 client profiles. This results in the user not being able to upgrade without removing OAuth2 client profiles.

      Relevant stacktrace from the log file:

      ERROR: An error occurred while trying to look for upgradable OAuth2 client profiles
      java.lang.NullPointerException
      	at org.forgerock.openam.upgrade.steps.UpgradeOAuth2ClientStep.addAttributeToMap(UpgradeOAuth2ClientStep.java:156)
      	at org.forgerock.openam.upgrade.steps.UpgradeOAuth2ClientStep.findUpgradableConfigs(UpgradeOAuth2ClientStep.java:140)
      	at org.forgerock.openam.upgrade.steps.UpgradeOAuth2ClientStep.initialize(UpgradeOAuth2ClientStep.java:85)
      	at org.forgerock.openam.upgrade.UpgradeServices.<init>(UpgradeServices.java:92)
      	at org.forgerock.openam.upgrade.UpgradeServices.getInstance(UpgradeServices.java:119)
      	at com.sun.identity.config.upgrade.Upgrade.<init>(Upgrade.java:55)
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                spareyc Charles Sparey
                Reporter:
                abel.hoxeng Abel Hoxeng
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 0h
                  0h
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 25h 1m
                  25h 1m