Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-5688

Drop support for legacy AMSDK IdRepo and remove ssoadm add-amsdk-idrepo-plugin sub-command

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: 11.0.0, 12.0.0, 13.0.0
    • Fix Version/s: None
    • Component/s: CLI, console
    • Labels:
      None
    • Rank:
      1|hzpbgn:

      Description

      The add-amsdk-idrepo-plugin sub-command adds support for a legacy IdRepo facility that is only possible when using ODSEE as a user store and there was a need to provide proprietary role-based authentication and services.

      There are a number of code-paths in OpenAM that check for AMSDK being enabled that could also be cleaned up as a result of removing this facility.

        Attachments

          Activity

            People

            • Assignee:
              peter.major Peter Major [X] (Inactive)
              Reporter:
              markdr Mark de Reeper
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: