Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-6553

Fix Social Authentication in subrealms

    Details

    • Sprint:
      AM Sustaining Sprint 14
    • Support Ticket IDs:

      Description

      Social Authentication is broken in OpenAM 12.01.
      you see the result of the /json/authentication post call instead of getting redirected to the profile page (or the goto if you have specified one)

      Steps to reproduce:
      1. configure Google for social authentication and set it up as the default chain in a subrealm
      2. start incognito window, navigate to AM login page of the subrealm
      3. you get redirected to Google
      4. Login at google
      5. You get redirected back to OpenAM but only see the result of rest call in the browser

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                peter.major Peter Major [X] (Inactive)
                Reporter:
                bassteen Bas Steen
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 7h
                  7h