Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-690

Unprotected IIS Websites Stopped Working

    XMLWordPrintable

    Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • Agents-3.0.2, Express8
    • Agents-3.1.0-Xpress
    • web agents
    • Rank:
      1|hzn4vz:

      Description

      After configuring the IIS web Policy Agent for the target website, all the rest of the other IIS websites stopped working.
      However, the protected website, which the agent has been configured for, works with no issues (Properly redirects to the opensso).

      Note:

      • I have tested with both stable and nightly builds, however the same behavior is perceived.
      • I have configured and tested the IIS 7 web agent (Version: 3.0.1) earlier as a proof of concept and have not faced any issues.
        Could you please advise whether there are archived versions of the IIS Web Agent (Both 32 & 64 bit)?

      Event viewer is showing the following three exceptions:

      (1)
      Faulting application name: w3wp.exe, version: 7.5.7600.16385, time stamp: 0x4a5bd0eb
      Faulting module name: amsdk.dll, version: 0.0.0.0, time stamp: 0x4d4ac10a
      Exception code: 0xc0000005
      Fault offset: 0x000000000001d1e5
      Faulting process id: 0x1300
      Faulting application start time: 0x01cc1f52366c0527
      Faulting application path: c:\windows\system32\inetsrv\w3wp.exe
      Faulting module path: C:\web_agents\iis7_agent\bin\amsdk.dll
      Report Id: 7426e719-8b45-11e0-91b7-00155d016f03

      (2)
      The description for Event ID 0 from source Sun OpenSSO Policy Agent 3.0 for Microsoft IIS 7.0 cannot be found.
      Either the component that raises this event is not installed on your local computer or the installation is corrupted.
      You can install or repair the component on the local computer.

      If the event originated on another computer, the display information had to be saved with the event.

      The following information was included with the event:
      Sun OpenSSO Policy Agent 3.0 for Microsoft IIS 7.0: iisaPropertiesFilePathGet() failed.

      (3)
      The description for Event ID 0 from source Sun OpenSSO Policy Agent 3.0 for Microsoft IIS 7.0 cannot be found.
      Either the component that raises this event is not installed on your local computer or the installation is corrupted.
      You can install or repair the component on the local computer.

      If the event originated on another computer, the display information had to be saved with the event.

      The following information was included with the event:
      Iis7Agent.cpp(1015) Opening registry key HKEY_LOCAL_MACHINE\ failed with error code 2

        Attachments

        1. AgentTestSiteConfig303SB.txt
          0.9 kB
        2. amAgent.txt
          89 kB
        3. IIS_WebAgent_Reg.jpg
          76 kB
        4. IIS Web Agent Configuration Steps_303_SB.txt
          2 kB
        5. regedit.png
          38 kB
        6. screenshot-1.jpg
          62 kB

          Issue Links

            Activity

              People

              mareks Mareks Malnacs
              fmourtada fmourtada
              Votes:
              2 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: