Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-7348

Social Authentication links are broken in subrealms

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 12.0.0
    • Fix Version/s: 12.0.3, 13.0.0
    • Component/s: XUI
    • Labels:
    • Sprint:
      AM Sustaining Sprint 14, AM Sustaining Sprint 15

      Description

      Steps to reproduce:

      • set up social authn in a subrealm
      • visit /UI/Login?realm=/sub to trigger /XUI/#login/&realm=/sub kind of login

      The links on the rendered page do not reference the /sub realm anywhere, hence clicking on the icon will result in an authentication failure (No Configuration found error).

      Workaround:
      access XUI using /XUI/#login/sub format URL instead, then the links will work.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                peter.major Peter Major [X] (Inactive)
                Reporter:
                peter.major Peter Major [X] (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 6h
                  6h