Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-7350

Incorrect hyphen character breaking copy/paste examples

    Details

    • Sprint:
      Sprint 105 - Team Shakespeare
    • Story Points:
      0.5

      Description

      I have come across an issue running examples from the OpenAM installation documentation: https://backstage.forgerock.com/#!/docs/openam/12.0.0/install-guide

      In a number of the dsconfig examples, if you copy and paste (manually or by using the copy web button) the examples fail when you try to run them.

      I have attached two images. The first is an example of the relevant section of the docs. The 2nd is what that copy/paste looks like in evernote. It is very subtle but you can see the hyphen's are slightly different for defaultAdd and filename.

      This difference results in the following error if you copy paste this straight into a terminal:

      An error occurred while parsing the command-line arguments: Argument

      "—-defaultAdd" does not start with one or two dashes and unnamed trailing

      arguments are not allowed

      All of which is a bit confusing.

      Feel free to contact me for clarification.

        Attachments

        1. bug1.png
          bug1.png
          56 kB
        2. bug2.png
          bug2.png
          32 kB

          Activity

            People

            • Assignee:
              chris.lee Chris Lee
              Reporter:
              wayne.blacklock Wayne Blacklock
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: