Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-7438

OpenAM 12 documentation is pointing at non-existent WPA 3.3.0 User Guide

    Details

    • Sprint:
      Sprint 100 - Team Shakespeare, Sprint 103 - Team Shakespeare, Sprint 104 - Team Shakespeare, Sprint 105 - Team Shakespeare
    • Story Points:
      2

      Description

      We had a report that the 3.3.0 WPA User's Guide is missing from backstage (which is true, it wasn't introduced until 3.5.0). The problem was traced back to some links in OpenAM 12.0.0 docs:

      ./openam/12.0.0/docbook/admin-guide/chap-federation.xml:     <link xlink:href="http://docs.forgerock.org/en/openam-pa/3.3.0/web-users-guide/#web-users-guide" xlink:show="new"><citetitle>Web Policy Agent User's Guide</citetitle></link>
      ./openam/12.0.0/docbook/admin-guide/chap-oauth2.xml:      <link xlink:href="http://docs.forgerock.org/en/openam-pa/3.3.0/web-users-guide/#web-users-guide" xlink:show="new"><citetitle>Web Policy Agent User's Guide</citetitle></link>
      ./openam/12.0.0/docbook/admin-guide/chap-sso.xml:             <link xlink:href="http://docs.forgerock.org/en/openam-pa/3.3.0/web-users-guide/#web-users-guide" xlink:show="new"><citetitle>OpenAM Web Policy Agent User's Guide</citetitle></link>
      ./openam/12.0.0/docbook/admin-guide/chap-sso.xml:             <link xlink:href="http://docs.forgerock.org/en/openam-pa/3.3.0/web-users-guide/#web-users-guide" xlink:show="new"><citetitle>OpenAM Web Policy Agent User's Guide</citetitle></link>
      ./openam/12.0.0/docbook/install-guide/chap-install-core.xml:  <link xlink:show="new" xlink:href="http://docs.forgerock.org/en/openam-pa/3.3.0/web-users-guide/#web-users-guide"><citetitle>OpenAM Web Policy Agent User's Guide</citetitle></link>,
      ./openam/12.0.0/docbook/install-guide/chap-uninstall.xml:  <link xlink:show="new" xlink:href="http://docs.forgerock.org/en/openam-pa/3.3.0/web-users-guide/#web-users-guide"><citetitle>OpenAM Web Policy Agent User's Guide</citetitle></link>,
      ./openam/12.0.0/docbook/upgrade-guide/chap-upgrade-components.xml:    <link xlink:show="new" xlink:href="http://docs.forgerock.org/en/openam-pa/3.3.0/web-users-guide/#web-users-guide"><citetitle>OpenAM Web Policy Agent User's Guide</citetitle></link>.
      Binary file ./openam/12.0.0/pdf/OpenAM-12.0.0-Admin-Guide.pdf matches
      Binary file ./openam/12.0.0/pdf/OpenAM-12.0.0-Getting-Started.pdf matches
      Binary file ./openam/12.0.0/pdf/OpenAM-12.0.0-Install-Guide.pdf matches
      Binary file ./openam/12.0.0/pdf/OpenAM-12.0.0-Upgrade-Guide.pdf matches
      

      and...

      Basically the link exists in the following docs:
      ./openam/12.0.0/docbook/admin-guide/chap-federation.xml
      ./openam/12.0.0/docbook/admin-guide/chap-oauth2.xml
      ./openam/12.0.0/docbook/admin-guide/chap-sso.xml
      ./openam/12.0.0/docbook/install-guide/chap-install-core.xml
      ./openam/12.0.0/docbook/install-guide/chap-uninstall.xml
      ./openam/12.0.0/docbook/upgrade-guide/chap-upgrade-components.xml
      ./openam/12.0.0/pdf/OpenAM-12.0.0-Admin-Guide.pdf
      ./openam/12.0.0/pdf/OpenAM-12.0.0-Getting-Started.pdf 
      ./openam/12.0.0/pdf/OpenAM-12.0.0-Install-Guide.pdf
      ./openam/12.0.0/pdf/OpenAM-12.0.0-Upgrade-Guide.pdf matches
      

      This JIRA is to investigate those links, and remedy the problem that they end in 404 as things stand.

        Attachments

          Activity

            People

            • Assignee:
              chris.lee Chris Lee
              Reporter:
              chris.lee Chris Lee
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: