Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-7556

Upgrade from 11.0.3/12.0.0 to 13.0.0 breaks Windows Desktop SSO

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 11.0.3, 12.0.0, 13.0.0
    • Fix Version/s: 13.0.0
    • Component/s: authentication, upgrade
    • Environment:
      OpenAM 13.0.0-SNAPSHOT Build 3c3d1dc7ea (2015-November-24 01:49)
    • Support Ticket IDs:

      Description

      Authentication now fails as unauthorized. More information to come.

      With the upgrade to OpenAM 13.0.0 the Kerberos Trusted Realm attribute is added to the authentication module this requires there to be a list of realms which are deemed to be accessed from the kerberos server, the realm in question should be named after the domain the the KS is on in the case of my testing this was INTERNAL.FORGEROCK.COM.

      To resolve the authentication from failing I had to create a realm with the name of the domain and add this to the trusted realms list in the Windows Desktop SSO Module, then on login I had to give this as the realm I wished to authenticate against.

      Windows Desktop SSO will no longer work in top level realm.

      The docs at http://openam.forgerock.org/doc/bootstrap/admin-guide/index.html#desktop-module-conf-hints do not contain any pertenent information about this and require updating, will be referenced in a seperate bug.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tom.rumsey Emma Rumsey [X] (Inactive)
                Reporter:
                amrwalk Alex Walker [X] (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: