Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-792

SAML2 Metadata for a remote service provider with Extensions breaks the console and Entity Providers no longer list under Federation

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 9.5.3
    • Fix Version/s: 9.5.4_RC1, 10.0.0-EA
    • Component/s: SAML
    • Labels:
      None
    • Environment:
      Ubuntu 10.04, Tomcat 6, JVM Version: 1.6.0_20, OpenAM 10_RC1 (2011-August-14 00:13)
    • Sprint:
      Sprint 3

      Description

      Whenever I goto Common Tasks -> Register Remote Service Provider
      Where does the metadata file reside? File

      I select the file and it uploads with NO ERRORS. However, whenever I goto the Federation tab, none of my entities list under the Entity Providers pane. It seems that the Extensions in the SP metadata cause the break.

      <md:Extensions>
      <DiscoveryResponse xmlns="urn:oasis:names:tc:SAML:profiles:SSO:idp-discovery-protocol" Binding="urn:oasis:names:tc:SAML:profiles:SSO:idp-discovery-protocol" Location="https://login-dev.nterlearning.org/Shibboleth.sso/DS" index="1"/>
      </md:Extensions>

      This is a huge problem because I have to re-install OpenAM and re-configure everything (using metadata without the Extensions) to be able to see the entities. I've tried to delete the offending entity provider metadata from within the circle of trust in the GUI and using the command line admin tools, but the system won't let me and calls an error. The bug is in the stable release, and I tried the nightly release today with the same bug. I have to delete OpenAM and re-install for things to work again.

      This bug seems to have a "sister" bug that has already been fixed for remote IDPs (but I guess not SPs):
      https://bugster.forgerock.org/jira/browse/OPENAM-13

      Thank you!

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                peter.major Peter Major
                Reporter:
                thatchickinpa thatchickinpa
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: