Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-8065

WPA4 agentadmin installer fails in send_session_request when notifications are disabled in OpenAM

    XMLWordPrintable

    Details

    • Rank:
      1|hzqtbb:

      Description

      Create agent profile in OpenAM and turn off all notification support. Run agentadmin to install the agent instance. It fails with the following message in installer_log:

      2016-01-08 10:11:13 send_session_request(): response status code: 200
      <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
      <ResponseSet vers="1.0" svcid="session" reqid="0">
      <Response><![CDATA[<SessionResponse vers="1.0" reqid="1">
      <GetSession>
      ...........
      </Session></GetSession>
      </SessionResponse>]]></Response>
      <Response><![CDATA[<SessionResponse vers="1.0" reqid="2">
      <AddSessionListener>
      <Exception>AQIC5wM.......* http://host/openam/sessionservice</Exception>
      </AddSessionListener>
      </SessionResponse>]]></Response>
      </ResponseSet>
      2016-01-08 10:11:13 send_session_request(): status: error
      2016-01-08 10:11:13 am_agent_login(): closing connection after failure

        Attachments

          Activity

            People

            mareks Mareks Malnacs
            mareks Mareks Malnacs
            Filip Kubáň [X] Filip Kubáň [X] (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: