Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-8406

Agent 4.0.0 can not process the default apache2 config on Unbuntu 14.04


    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: Agents-4.0.0
    • Fix Version/s: None
    • Component/s: web agents
    • Environment:
      Ubuntu 14.0.4
      Agent Apache_v2.4_Linux_64bit_4.0.0.zip
    • Support Ticket IDs:


      Agent 4.0.0 does not work with the default ubuntu (14.04) configuration for apache2.

      Steps to recreate

      1) Set up machine with Ubuntu server version 14.04 on it.

      2) Install apache2 using sudo apt-get-install-apache2

      3) Follow steps in https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-14-04-lts to create a site

      4) Now unzip Apache_v2.4_Linux_64bit_4.0.0.zip

      5) Now attempt to install agent ./agentadmin --install

      After entering location of config file, we get an error message "Error: invalid server configuration"

      In the logs we get the following

      2016-02-22 15:37:41  OpenAM Web Agent for Apache Server interactive installation
      2016-02-22 15:37:41  license was accepted earlier
      2016-02-22 15:38:02  Found group ${APACHE_RUN_GROUP}, gid 0
      2016-02-22 15:38:02  could not locate LoadModule configuration directive in /etc/apache2/apache2.conf

      What has been tried

      Agent 3.3.4 - This got past the stage of verifying the config

      Taking the default httpd conf from the downloaded httpd distribution and using this with the agent - This also worked

      So it seems that the issue was probably introduced in Agent 4.0.0


          Issue Links



              • Assignee:
                edward.barker edwardb
              • Votes:
                2 Vote for this issue
                8 Start watching this issue


                • Created: