Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-8468

Incorrect preauthentication custom message with XUI.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 12.0.0, 12.0.2
    • Fix Version/s: 12.0.5
    • Component/s: authentication, XUI
    • Labels:
    • Support Ticket IDs:

      Description

      When XUI is enabled OpenAM will show incorrect message, if module throws error before authentication.

      Step to reproduce:
      1. Get example from documentation - https://backstage.forgerock.com/#!/docs/openam/12.0.0/dev-guide/chap-auth-spi
      2. Add case when module returns STATE_ERROR and sets custom error message at STATE_BEGIN state.
      3. Open example authentication module.

      Result with XUI disabled:
      Custom error message is show on the page.

      Result with XUI enabled:
      "Unable to login to OpenAM" message is show on the page.

      Source with modified example is attached.

      To initiate preauthentication error need to add 'preautherror' parameter to query URL (example: 'http://openam.example.com:8080/openam/UI/Login?module=Sample&preautherror=1')

        Attachments

          Activity

            People

            • Assignee:
              kamal.sivanandam@forgerock.com Kamal Sivanandam
              Reporter:
              WorkTest Mike -
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: