Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-8998

Completing USS Forgot Password flow results in lost goto parameter on Return to Login Page link

    Details

    • Support Ticket IDs:

      Description

      Completing the common user self-service Forgot Password flow in OpenAM 13 results in the goto parameter being lost when clicking the "Return to Login Page" at the end.

      To reproduce current behaviour:

      1). OpenAM 13 > configure "User Self Service" > Forgotten Password enabled and KBA enabled. Create a test user and set a KBA response.

      2). Access:

      http://openam.example.com:8080/OpenAM-13.0.0/XUI/#login/&goto=http://forgerock.com
      

      3). Click the Forgot Password link and follow the steps to reset the password.

      4). When the "Your password has been successfully reset" page appears click on the "Return to Login Page" link. Note that the goto is now no longer present.

      Expected behaviour:

      The "Return to Login Page" link should contain the preserved goto parameter.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                julian.kigwana@forgerock.com Julian Kigwana [X] (Inactive)
                Reporter:
                andy.itter Andy Itter
                QA Assignee:
                Joanna Wasilewska [X] (Inactive)
              • Votes:
                1 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: