Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-9447

OAuth2 client has different default values for clean installation and upgraded AM from 13.0.0 to 13.5

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 13.5.0, 14.0.0
    • Fix Version/s: None
    • Component/s: upgrade
    • Environment:
      OpenAM 13.5.0 Build 550cfe7d60 (2016-July-13 08:43)

      Description

      OAuth2 client has different default values for clean installation and upgraded AM from 13.0.0 to 13.5. I am not able to reproduce this case, if I done an upgrade from 12.0.3 to 13.5

      Steps to reproduce

      1.) Default installation of AM 13.0.0
      2.) Perform an upgrade to AM 13.5
      3.) Create an OAuth2 client (/ realm / Agents / OAuth 2.0/OpenID Connect Client)

      Observed result

      Json Web Key URI: empty
      Public key selector: X509

      Expected result:

      Json Web Key URI: http://openam.test.forgerock.com:8080/openam/oauth2/<REALM NAME>/connect/jwk_uri
      Public key selector: JWKs_URI

      Workaround

      set these properties by hand

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                richard.hruza Richard Hruza
                QA Assignee:
                Richard Hruza
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: