Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-9585

The default setup for OpenDJ for internal and external user stores should use "member" rather than "uniqueMember" for allocating members to a group

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 13.5.0
    • Fix Version/s: None
    • Component/s: configurator
    • Labels:
      None
    • Rank:
      1|hzrtnz:

      Description

      The default set up for OpenDJ for internal and external user stores has uniqueMember as the attribute for assigning members to a group. It should really be member like Active Directory.

      When I was trying to create a rest request to add a member to a group I came across the following problem. If I am using an internal OpenDJ as a userstore then I need to use a request similar to the folowing

      PUT http://ed-am2.test.forgerock.com:18081/openam/json/groups/group1 HTTP/1.1
      Accept-Encoding: gzip,deflate
      iPlanetDirectoryPro: AQIC5wM2LY4Sfcx6rAv2loL1wRu4DjXX5Z2mWXgyqEMJGeY.*AAJTSQACMDEAAlNLABQtMjE0MzczOTM1NDE0Mzg2ODU2OAACUzEAAA..*
      Content-Type: application/json
      Content-Length: 52
      Host: ed-am2.test.forgerock.com:18081
      Connection: Keep-Alive
      User-Agent: Apache-HttpClient/4.1.1 (java 1.5)
      
      {"uniqueMember":["cn=ebtest1,cn=users,dc=example,dc=com"]}
      

      Wherea when I am using Active Directory as a userstore I need to use a request similar to

      PUT http://ed-am2.test.forgerock.com:18081/openam/json/groups/group1 HTTP/1.1
      Accept-Encoding: gzip,deflate
      iPlanetDirectoryPro: AQIC5wM2LY4Sfcx6rAv2loL1wRu4DjXX5Z2mWXgyqEMJGeY.*AAJTSQACMDEAAlNLABQtMjE0MzczOTM1NDE0Mzg2ODU2OAACUzEAAA..*
      Content-Type: application/json
      Content-Length: 52
      Host: ed-am2.test.forgerock.com:18081
      Connection: Keep-Alive
      User-Agent: Apache-HttpClient/4.1.1 (java 1.5)
      
      {"member":["cn=ebtest1,cn=users,dc=example,dc=com"]}
      

      This problem was noticed on OpenAM13.5.0

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              edward.barker edwardb
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated: