At the moment the api/explorer page that shows the described endpoints misses the consistency in the names.
Some endpoints have the "Resource" in their names some have "Endpoint" etc.
We should have a consistency in these titles which is plural name of the endpoint if the endpoint is CollectionProvider or singular is it's a SingletonProvider
Core Token Resources --> Core Tokens
Resource Set Resource Endpoint --> Resource Set Resources
Dashboard Resource --> Dashboard