Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-9660

SecurID Authentication not working, giving Unknown error. Please contact your Administrator

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 13.5.0
    • Fix Version/s: None
    • Component/s: authentication, security
    • Labels:
    • Environment:
      Linux
    • Rank:
      1|hzs2r3:

      Description

      I am trying authenticate against securID RSA server via openAM but its failing.

      I have openAM 13.5 installed on Linux box with default configuration.

      1. I deployed openAM13.5 war in tomcat
      2. copied authapi.jar and crypto.jar to WEB-INF/lib
      3. Copied sdconf file to configuration directory ~/OpenAM-13.5.0/OpenAM-13.5.0/auth/ace/data.
      4. Created Module 'SecurID'. Created Chain 'rsachain'. set it is 'sufficient'.
      5. Went to login at : http://server:port/OpenAM-13.5.0/XUI/#login?realm=openam&module=SecurID

      After i enter username & passcode,
      I am getting 'Unknown error. Please contact your Administrator'.

      I tried following.

      1. i tried to change setting at rsa_api.properties @ ~/OpenAM-13.5.0/OpenAM-13.5.0/auth/ace/data/ to see logs. No log file is getting created.

      2. I updated log4j.properties in same /OpenAM-13.5.0/OpenAM-13.5.0/auth/ace/data/ but still no log.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                ranvir ranvir raol [X] (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: