Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-9668

Some of our 15000 Users with slow network connection complain about delays and aborts while accessing our page

    Details

    • Support Ticket IDs:

      Description

      Hi,
      some of our 15000 Users with slow network connection complained about delays and aborts while accessing our page. They report, that while loading the login-screen they end up on a "white page"

      We could reproduce this using the throttle-feature in Chrome Developer Tools. If we change it to "GPRS" the loading of our page takes ages und even stops.

      We could trace the issue to \tomcat\webapps\login\XUI\index.html

      The section:
      var require =

      { urlArgs : "v=13.0.0", deps : ['main'] }

      ;
      loads main.js which can take lot of time before forwarding to the login-page. We found out, that as no timeout is specified, at least in some browsers the loading stops after 20s and the user gets stuck.
      Therefore we added
      waitSeconds: 300,
      so at least the loading continues after 20s

      So we have two questions:
      1) Is adding the waitSeconds-attribute supported by forgerock?
      2) How can we solve this issue? Is there a way to minimze/optimize the amount of loaded java script libraries?

      Let me know if you have further questions

      BR
      Deniz

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                peter.major Peter Major [X] (Inactive)
                Reporter:
                kvhessen Christian Lippert
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: