Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-9743

After importing config using export-svc-cfg policies are not displayed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 13.5.0
    • Fix Version/s: None
    • Component/s: policy editor, ssoadm
    • Labels:
      None
    • Support Ticket IDs:

      Description

      Export and reimport a service configuration with policies and the policies no longer appear in the policy editor.

      Steps to reproduce:

      Vanilla install 13.5.0
      Top realm create a new policy set.
      Create policies
      Export configuration
      "./ssoadm export-svc-cfg -u amadmin -f /tmp/pwd.txt -e openam -o export-svc-cfg.xml"
      Then importing the configuration with:
      "./ssoadm import-svc-cfg -u amadmin -f /tmp/pwd.txt -e openam -X export-svc-cfg.xml"
      Policy set will not display.

      Adding a new policy set will display the older one but policies are still missing.
      Reference to policies still present if you export via policy Editor.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                peter.major Peter Major
                Reporter:
                jonthomas Jonathan Thomas
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: