Uploaded image for project: 'OpenDJ'
  1. OpenDJ
  2. OPENDJ-6488

Non-obvious error message from setup when using outdated Java

    Details

    • Type: Bug
    • Status: Done
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 7.0.0
    • Fix Version/s: Not applicable
    • Component/s: setup
    • Labels:
      None
    • Story Points:
      1

      Description

      Users would rather see something like "Java 8 is no longer supported. Upgrade to at least Java 11.0.3." Not "An unexpected error has been raised during setup: 'java.lang.StringBuilder'":

      $ export JAVA_HOME=/usr/lib/jvm/java-8-openjdk-amd64
      $ mvn -Dformats=html
      ...
      [INFO] --- exec-maven-plugin:1.5.0:exec (set-up-opendj) @ schema-reference ---
      
      Store the following deployment key (deployment key password is the same as the
      root user password) in a safe place and re-use it when configuring other
      servers in the topology:
      
      ACwAGQ5uyVtVHx6ifwN70K7wAJmpRw5CBVN1bkVDAIwhNPLgKLy0Fiw
      
      Validating parameters..... Done
      An unexpected error has been raised during setup: 'java.lang.StringBuilder'
      See /tmp/opendj-setup-3535527918245789417.log for a detailed log of the failed
      operation.
      Please report this error and provide the log file mentioned above.
      [ERROR] Command execution failed.
      org.apache.commons.exec.ExecuteException: Process exited with an error: 1 (Exit value: 1) 

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                JnRouvignac Jean-Noël Rouvignac
                Reporter:
                Mark Mark Craig
                Dev Assignee:
                Jean-Noël Rouvignac
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: