Uploaded image for project: 'OpenDJ'
  1. OpenDJ
  2. OPENDJ-941

Package Upgrade: pre-install script should call stop-ds if the instance is not configured

    XMLWordPrintable

    Details

    • Improvement
    • Status: Done
    • Minor
    • Resolution: Fixed
    • 2.6.0
    • 2.6.0
    • tools

      Description

      Scenario:
      1. install OpenDJ package (deb or rpm)
      2. remove OpenDJ package
      3. check that /opt/opends has been removed
      => the /opt/opends has not been completely removed and contains the following file: /opt/opendj/locks/server.lock
      => in fact this file has been generated by the stop-ds command called in the pre-install script

      If the instance is not configured, the pre-install script should not call the stop-ds command.

        Attachments

          Activity

            People

            violette Violette Roche Montane
            csovant Christophe Sovant
            Christophe Sovant Christophe Sovant
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: