Uploaded image for project: 'OpenIDM'
  1. OpenIDM
  2. OPENIDM-11571

Unable to update IDM from 5.5.x.x to 6.0.0.1

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not a defect
    • Affects Version/s: 6.0.0.1
    • Fix Version/s: None
    • Component/s: _Update
    • Labels:

      Description

      update.json in 6.0.0.1 contains this:

       

      "origin": {
      "product": "OpenIDM",
      "version": [
      "[6.0.0,6.0.0.1)"
      ]
      },
      

      If we would like to support update directly from 5.5.x.x to 6.0.0.1, we need to update version within origin.

       

       

      Steps to reproduce:

      1. for example install OpenIDM 5.5.0 with a JDBC repo (tested on MySQL)
      2. start OpenIDM
      3. cp IDM-6.0.0.1.zip  openidm/bin/update/
      4. ./cli.sh update  --acceptLicense --user openidm-admin:openidm-admin --url http://localhost:8080/openidm IDM-6.0.0.1.zip

      Expected result: IDM is updated;

      Actual result: IDM is not updated, please look at output below.

       

      kuba@kuba-profiq:~/Documents/idm6001/fullBits/update/openidm$ ll bin/update/
      total 145856
      drwxrwxr-x 2 kuba kuba 4096 srp 24 10:35 ./
      drwxrwxr-x 7 kuba kuba 4096 srp 24 10:24 ../
      -rw-rw-r-- 1 kuba kuba 149332823 srp 24 10:35 IDM-6.0.0.1.zip
      
      kuba@kuba-profiq:~/Documents/idm6001/fullBits/update/openidm$ ./cli.sh update --acceptLicense --user openidm-admin:openidm-admin --url http://localhost:8080/openidm IDM-6.0.0.1.zip
      Executing ./cli.sh...
      Starting shell in /home/kuba/Documents/idm6001/fullBits/update/openidm
      Aug 24, 2018 10:38:27 AM org.forgerock.openidm.core.FilePropertyAccessor loadProps
      INFO: Using properties at /home/kuba/Documents/idm6001/fullBits/update/openidm/conf/boot/boot.properties
      A valid archive was not found in the bin/update directory. Requested filename was = IDM-6.0.0.1.zip
      Invalid archive(s) were found:
      IDM-6.0.0.1.zip: The archive IDM-6.0.0.1.zip can be used only to update version '[[6.0.0,6.0.0.1)]' and you are running version 5.5.0 
      ERROR: Error during execution. The state of OpenIDM is now unknown. Last Attempted step was PREVIEW_ARCHIVE. Now attempting recovery steps.
      

      Tested on OpenIDM version "6.0.0.1" (build: 20180807165505, revision: bda932e) jenkins-openidm-release-sustaining%2F6.0.x-23.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                naren.koganti Naren Koganti
                Reporter:
                jakub.janoska Jakub Janoska [X] (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: