Uploaded image for project: 'OpenIDM'
  1. OpenIDM
  2. OPENIDM-12095

OpenIDM 5.0.x doesn't start on WIndows 2016 server with OrientDB as repo.

    Details

      Description

      It's not possible to start OpenIDM 5.0.x on Windows 2016 Server. Affected all 5.0.x versions.

      OpenIDM 5.5.x and OpenIDM 6.0.x is working correctly on the same machine.

      We had very similar issue for Windows 2012 - OPENIDM-5226.

      Using boot properties at C:\Users\Administrator\Downloads\IDM-5.0.1.1\openidm\conf\boot\boot.properties
      Nov 09, 2018 10:40:18 AM org.forgerock.openidm.metadata.impl.ProviderTracker initBundleProviders
      WARNING: Failed to obtain meta-data on handling configuration for org.forgerock.openidm.repo-orientdb
      java.lang.ClassNotFoundException: org.forgerock.openidm.repo.orientdb.metadata.ConfigMeta
       at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1911)
       at org.apache.felix.framework.BundleImpl.loadClass(BundleImpl.java:978)
       at org.forgerock.openidm.metadata.impl.ProviderTracker.initBundleProviders(ProviderTracker.java:88)
       at org.forgerock.openidm.metadata.impl.ProviderTracker.<init>(ProviderTracker.java:62)
       at org.forgerock.openidm.config.crypto.ConfigCrypto.<init>(ConfigCrypto.java:75)
       at org.forgerock.openidm.config.crypto.ConfigCrypto.getInstance(ConfigCrypto.java:91)
       at org.forgerock.openidm.config.installer.JSONConfigInstaller.start(JSONConfigInstaller.java:77)
       at org.forgerock.openidm.config.persistence.Activator.start(Activator.java:54)
       at org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:697)
       at org.apache.felix.framework.Felix.activateBundle(Felix.java:2226)
       at org.apache.felix.framework.Felix.startBundle(Felix.java:2144)
       at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)
       at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
       at java.lang.Thread.run(Thread.java:748)
      Caused by: org.osgi.framework.BundleException: Unable to resolve org.forgerock.openidm.repo-orientdb [11](R 11.0): missing requirement [org.forgerock.openidm.repo-orientdb [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=com.orientechnologies.orient.server)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve com.orientechnologies.orientdb-server [178](R 178.0): missing requirement [com.orientechnologies.orientdb-server [178](R 178.0)] osgi.wiring.package; (osgi.wiring.package=com.orientechnologies.orient.core.cache) [caused by: Unable to resolve com.orientechnologies.orientdb-core [175](R 175.0): missing requirement [com.orientechnologies.orientdb-core [175](R 175.0)] osgi.wiring.package; (osgi.wiring.package=org.xerial.snappy) [caused by: Unable to resolve org.xerial.snappy.snappy-java [9](R 9.0): missing requirement [org.xerial.snappy.snappy-java [9](R 9.0)] osgi.native; (|(&(osgi.native.osname~=win32)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=win32)(osgi.native.processor~=x86))(&(osgi.native.osname~=macosx)(osgi.native.processor~=x86))(&(osgi.native.osname~=macosx)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=linux)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=linux)(osgi.native.processor~=x86))(&(osgi.native.osname~=linux)(osgi.native.processor~=arm))(&(osgi.native.osname~=linux)(osgi.native.processor~=ppc64))(&(osgi.native.osname~=linux)(osgi.native.processor~=ppc64le))(&(osgi.native.osname~=aix)(osgi.native.processor~=ppc64))(&(osgi.native.osname~=sunos)(osgi.native.processor~=x86))(&(osgi.native.osname~=sunos)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=sunos)(osgi.native.processor~=sparc)))]]] Unresolved requirements: [[org.forgerock.openidm.repo-orientdb [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=com.orientechnologies.orient.server)(version>=1.7.0)(!(version>=2.0.0)))]
       at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)
       at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1904)
       ... 13 more
      
      Nov 09, 2018 10:40:18 AM org.forgerock.openidm.logging.LogServiceTracker logEntry
      SEVERE: Bundle: org.forgerock.openidm.repo-orientdb [11] FrameworkEvent ERROR
      org.apache.felix.log.LogException: org.osgi.framework.BundleException: Unable to resolve org.forgerock.openidm.repo-orientdb [11](R 11.0): missing requirement [org.forgerock.openidm.repo-orientdb [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=com.orientechnologies.orient.server)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve com.orientechnologies.orientdb-server [178](R 178.0): missing requirement [com.orientechnologies.orientdb-server [178](R 178.0)] osgi.wiring.package; (osgi.wiring.package=com.orientechnologies.orient.core.cache) [caused by: Unable to resolve com.orientechnologies.orientdb-core [175](R 175.0): missing requirement [com.orientechnologies.orientdb-core [175](R 175.0)] osgi.wiring.package; (osgi.wiring.package=org.xerial.snappy) [caused by: Unable to resolve org.xerial.snappy.snappy-java [9](R 9.0): missing requirement [org.xerial.snappy.snappy-java [9](R 9.0)] osgi.native; (|(&(osgi.native.osname~=win32)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=win32)(osgi.native.processor~=x86))(&(osgi.native.osname~=macosx)(osgi.native.processor~=x86))(&(osgi.native.osname~=macosx)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=linux)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=linux)(osgi.native.processor~=x86))(&(osgi.native.osname~=linux)(osgi.native.processor~=arm))(&(osgi.native.osname~=linux)(osgi.native.processor~=ppc64))(&(osgi.native.osname~=linux)(osgi.native.processor~=ppc64le))(&(osgi.native.osname~=aix)(osgi.native.processor~=ppc64))(&(osgi.native.osname~=sunos)(osgi.native.processor~=x86))(&(osgi.native.osname~=sunos)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=sunos)(osgi.native.processor~=sparc)))]]] Unresolved requirements: [[org.forgerock.openidm.repo-orientdb [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=com.orientechnologies.orient.server)(version>=1.7.0)(!(version>=2.0.0)))]
       at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)
       at org.apache.felix.framework.Felix.loadBundleClass(Felix.java:1904)
       at org.apache.felix.framework.BundleImpl.loadClass(BundleImpl.java:978)
       at org.forgerock.openidm.metadata.impl.ProviderTracker.initBundleProviders(ProviderTracker.java:88)
       at org.forgerock.openidm.metadata.impl.ProviderTracker.<init>(ProviderTracker.java:62)
       at org.forgerock.openidm.config.crypto.ConfigCrypto.<init>(ConfigCrypto.java:75)
       at org.forgerock.openidm.config.crypto.ConfigCrypto.getInstance(ConfigCrypto.java:91)
       at org.forgerock.openidm.config.installer.JSONConfigInstaller.start(JSONConfigInstaller.java:77)
       at org.forgerock.openidm.config.persistence.Activator.start(Activator.java:54)
       at org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:697)
       at org.apache.felix.framework.Felix.activateBundle(Felix.java:2226)
       at org.apache.felix.framework.Felix.startBundle(Felix.java:2144)
       at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)
       at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
       at java.lang.Thread.run(Thread.java:748)
      
      Nov 09, 2018 10:40:19 AM org.forgerock.openidm.logging.LogServiceTracker logEntry
      SEVERE: Bundle: org.xerial.snappy.snappy-java [9] FrameworkEvent ERROR
      org.apache.felix.log.LogException: org.osgi.framework.BundleException: Unable to resolve org.xerial.snappy.snappy-java [9](R 9.0): missing requirement [org.xerial.snappy.snappy-java [9](R 9.0)] osgi.native; (|(&(osgi.native.osname~=win32)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=win32)(osgi.native.processor~=x86))(&(osgi.native.osname~=macosx)(osgi.native.processor~=x86))(&(osgi.native.osname~=macosx)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=linux)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=linux)(osgi.native.processor~=x86))(&(osgi.native.osname~=linux)(osgi.native.processor~=arm))(&(osgi.native.osname~=linux)(osgi.native.processor~=ppc64))(&(osgi.native.osname~=linux)(osgi.native.processor~=ppc64le))(&(osgi.native.osname~=aix)(osgi.native.processor~=ppc64))(&(osgi.native.osname~=sunos)(osgi.native.processor~=x86))(&(osgi.native.osname~=sunos)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=sunos)(osgi.native.processor~=sparc))) Unresolved requirements: [[org.xerial.snappy.snappy-java [9](R 9.0)] osgi.native; (|(&(osgi.native.osname~=win32)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=win32)(osgi.native.processor~=x86))(&(osgi.native.osname~=macosx)(osgi.native.processor~=x86))(&(osgi.native.osname~=macosx)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=linux)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=linux)(osgi.native.processor~=x86))(&(osgi.native.osname~=linux)(osgi.native.processor~=arm))(&(osgi.native.osname~=linux)(osgi.native.processor~=ppc64))(&(osgi.native.osname~=linux)(osgi.native.processor~=ppc64le))(&(osgi.native.osname~=aix)(osgi.native.processor~=ppc64))(&(osgi.native.osname~=sunos)(osgi.native.processor~=x86))(&(osgi.native.osname~=sunos)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=sunos)(osgi.native.processor~=sparc)))]
       at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)
       at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)
       at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)
       at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
       at java.lang.Thread.run(Thread.java:748)
      
      Nov 09, 2018 10:40:19 AM org.forgerock.openidm.logging.LogServiceTracker logEntry
      SEVERE: Bundle: org.forgerock.openidm.repo-orientdb [11] FrameworkEvent ERROR
      org.apache.felix.log.LogException: org.osgi.framework.BundleException: Unable to resolve org.forgerock.openidm.repo-orientdb [11](R 11.0): missing requirement [org.forgerock.openidm.repo-orientdb [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=com.orientechnologies.orient.server)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve com.orientechnologies.orientdb-server [178](R 178.0): missing requirement [com.orientechnologies.orientdb-server [178](R 178.0)] osgi.wiring.package; (osgi.wiring.package=com.orientechnologies.orient.core.cache) [caused by: Unable to resolve com.orientechnologies.orientdb-core [175](R 175.0): missing requirement [com.orientechnologies.orientdb-core [175](R 175.0)] osgi.wiring.package; (osgi.wiring.package=org.xerial.snappy) [caused by: Unable to resolve org.xerial.snappy.snappy-java [9](R 9.0): missing requirement [org.xerial.snappy.snappy-java [9](R 9.0)] osgi.native; (|(&(osgi.native.osname~=win32)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=win32)(osgi.native.processor~=x86))(&(osgi.native.osname~=macosx)(osgi.native.processor~=x86))(&(osgi.native.osname~=macosx)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=linux)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=linux)(osgi.native.processor~=x86))(&(osgi.native.osname~=linux)(osgi.native.processor~=arm))(&(osgi.native.osname~=linux)(osgi.native.processor~=ppc64))(&(osgi.native.osname~=linux)(osgi.native.processor~=ppc64le))(&(osgi.native.osname~=aix)(osgi.native.processor~=ppc64))(&(osgi.native.osname~=sunos)(osgi.native.processor~=x86))(&(osgi.native.osname~=sunos)(osgi.native.processor~=x86-64))(&(osgi.native.osname~=sunos)(osgi.native.processor~=sparc)))]]] Unresolved requirements: [[org.forgerock.openidm.repo-orientdb [11](R 11.0)] osgi.wiring.package; (&(osgi.wiring.package=com.orientechnologies.orient.server)(version>=1.7.0)(!(version>=2.0.0)))]
       at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)
       at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)
       at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)
       at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
       at java.lang.Thread.run(Thread.java:748)
      

        Attachments

          Activity

            People

            • Assignee:
              patrickdiligent patrick diligent
              Reporter:
              jakub.janoska Jakub Janoska [X] (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: