Uploaded image for project: 'OpenIDM'
  1. OpenIDM
  2. OPENIDM-13023

Include an out of the box Oracle specific bnd file in db/oracle/scripts

    Details

    • Target Version/s:
    • Verified Version/s:
    • Story Points:
      1
    • Sprint:
      2019.11 - IDM

      Description

      The current approach (https://backstage.forgerock.com/docs/idm/6.5/install-guide/#oracle-osgi-bundles-hikari) of creating an Oracle DB bundle is to copy sqljdbc4.bnd from db/mssql/scripts, and modify the contents with:

      version=4.0
      Export-Package: *;version=${version}
      Bundle-Name: Oracle JDBC Driver 4.0 for SQL Server
      Bundle-SymbolicName: Oracle JDBC Driver 4.0 for SQL Server
      Bundle-Version: ${version}
      Import-Package: *;resolution:=optional

      The desired outcome is to have a default OOTB bnd file in db/oracle/scripts that looks like:

      version=12.2.0.1
      Export-Package: *;version=${version}
      Bundle-Name: Oracle Database 12.2.0.1 JDBC Driver
      Bundle-SymbolicName: oracle.jdbc.OracleDriver
      Bundle-Version: ${version}
      Import-Package: *;resolution:=optional

        Attachments

          Activity

            People

            • Assignee:
              emanuel.brici Emanuel Brici
              Reporter:
              yinyan.cao Yinyan Cao
              QA Assignee:
              Petr Bednar [X] (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: