Uploaded image for project: 'OpenIDM'
  1. OpenIDM
  2. OPENIDM-9359

Update from 5.0 to 5.5 via CLI on Linux does not prompt users to run update scripts

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: OpenIDM 5.5.0
    • Fix Version/s: OpenIDM 5.5.0
    • Component/s: _Update
    • Labels:
      None
    • Environment:
      CentOS 7, Ubuntu 14.04, IDM RC10, openidm-5.5.0-pre_updateSNAPSHOT.zip

      Description

      cli.sh process, 5.0 -> 5.5

      Update to 5.5 should prompt users to run repo update scripts. Instead it brings up the following message:

      Please enter the directory to save repository update files:
      test
      Repository scripts are in the following directory: test.
      Please come back and run the update again with --skipRepoUpdatePreview after updates have been reviewed.

      To reproduce:
      Follow the procedure described in https://qa-backstage.forgerock.com/docs/idm/5.5/install-guide/#update-cli

      What you should see:

      Repository scripts are in the following directory: test.
      Please apply the update scripts now. When complete, run the update again with the
      --skipRepoUpdatePreview option.

      Workaround:

      Tell readers (via doc) to ignore the message to "come back" and instead apply the repo update scripts now

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                brmiller Brendan Miller
                Reporter:
                Mike2 Mike Jang
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: