Uploaded image for project: 'Identity Gateway'
  1. Identity Gateway
  2. OPENIG-1955

UI: When route has no "name" attribute and user adds it in editor, "undefined" shows during saving changes and also in deploy confirmation message instead of that name

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 5.5.0
    • Fix Version/s: 5.5.0
    • Component/s: UI - Structured Editor
    • Labels:
      None
    • Environment:
      java version "1.8.0_144"
      Java(TM) SE Runtime Environment (build 1.8.0_144-b01)
      Jetty 9.4.6
      OpenIG 5.5.0-SNAPSHOT Build 6c7e0dd418 (2017-September-22 03:30)
      Chrome 61.0.3163.91
    • Sprint:
      OpenIG Sprint 112, OpenIG Sprint 113

      Description

      When the user copies for example 01-static.json route from documentation, open it in studio, add "name" attribute and Save, it should say something like "NAME successfully saved". When trying to deploy, confirmation dialog asks properly with the new name but confirmation message after deploy contains undefined again.

      Steps to reproduce:
      1) Start clean OpenIG
      2) Copy the 01-static.json from OpenIG Docs to config/routes
      3) Open openig/studio and editor for 01-static route
      4) Add name attribute
      5) Save settings and deploy
      Expected result: Confirmation messages contains new name.
      Actual result: Confirmation messages contains undefined.

      Can be seen in the attached video from 00:18.

        Attachments

          Activity

            People

            Assignee:
            ludek.hon.profiq Ludek Hon [X] (Inactive)
            Reporter:
            jan.hajovsky Jan Hajovsky
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: