Uploaded image for project: 'Identity Gateway'
  1. Identity Gateway
  2. OPENIG-209

Federation Gateway SAML2 SLO not working

    XMLWordPrintable

    Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 3.0.0
    • 3.0.0
    • SAML
    • - container: Tomcat 7
      - browser: Firefox
    • Sprint 39

      Description

      Found using revision 380.

      Scenario:

      • configure OpenAM as IDP
      • configure OpenIG as SP
      • go to OPENIG_URL/myapp
        => redirection to OpenAM login page
        => log in with user
      • go again to OPENIG_URL/myapp
        => direct access to the protected application as expected
      • go to OpenAM url
        => redirect to "User Edit" page as expected
      • now do a SP initiated SLO using OPENIG_URL/saml/SPInitiatedSLO
        => we get a blank page (no error in the OpenIG log files)

      Now to see if the user has been correctly log out:

      • go to OpenAM url
        => redirect to the OpenAM login page as expected
      • now go to OPENIG_URL/myapp
        => direct access to the protected application but in that case we should have a redirect to the OpenAM login page

      Seems that the logout is correctly done on IDP side but not on SP side.
      Same problem when doing IDP initiated SLO.

        Attachments

          Issue Links

            Activity

              People

              violette Violette Roche Montane
              csovant Christophe Sovant
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: