Thanks to @Mark dR, I've just noticed that we have two classes named the same:
- org.forgerock.openig.tools.jwt.JwtValidationContext - Used by CdSsoFilter to propagate across constraints - specifically used in dynamic validation of JWT attributes (i.e. nonce).
- org.forgerock.openig.filter.jwt.JwtValidationContext - used by JwtValidationFilter to propagate across constraints.
Header comment in both:
- Rename one to JwtValidatorContext? As it seems we cannot merge them as they have different behavior
- Rename the builder's context to ValidationContext ?