Uploaded image for project: 'Identity Gateway'
  1. Identity Gateway
  2. OPENIG-4756

http2 and IGX : PasswordReplyFilter does not perform authentication on SampleApp

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 7.0.0
    • Fix Version/s: 7.0.0, 7.0.0-micsvc-1.0.3
    • Component/s: Core, Standalone
    • Labels:
      None
    • Environment:
      OS : OSX-Catalina 10.15.4
      jdk : openjdk-11.0.7

      Description

      The current test with PRF working on response is failing
      The issue seems related to OPENIG-4755

      Steps to reproduce :

      • - git pull PyForge
      • - ./cleanup.py -f
      • - ./configure.py
      • - launch the following commands (on Linux/Mac), in the PyForge root directory :
        export PYFORGE_ROOT_DIR=`pwd`; source PyBot/OpenIG/tools/.qa_tools; ppth
      • - launch the tests with the following alias
        rig -s Filters/PasswordReplayFilter/PasswordReplayFilterOnResponse -t Filling_Simple_Login_Form_Should_Log_User_If_Authorized_On_Application -n
        Servers are then available for checks... (NB : test may have been modified, to expect the current error)
      • - ./cleanup.py -f

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              guillaume.sauthier Guillaume Sauthier
              Reporter:
              jcdevil Jean-Charles Deville
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: