Uploaded image for project: 'Identity Gateway'
  1. Identity Gateway
  2. OPENIG-4791

UI: Out of sync when deploying from route list

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 7.0.0
    • Fix Version/s: 7.0.0
    • Labels:
      None
    • Environment:
      Identity Gateway 7.0.0-SNAPSHOT Build b71d29fed1 (2020-July-15 16:41)
      Tomcat 9.0.34 & IG Standalone
      OpenJDK Runtime Environment (build 11.0.7+10-post-Ubuntu-2ubuntu218.04)
      Chrome 83.0.4103.116
    • Sprint:
      2020.10 - IG / Microservices
    • Story Points:
      2

      Description

      During first deploy of route, you can get Out of sync error. Also I was unable to reproduce with devtools opened (although disable cache was disabled).

       

      Steps to reproduce:

      Prerequisite: Clean IG

      1) Open studio

      2) Create a route using structured editor

      3) When you're on route edit page, click on routes button in header

      4) Try to deploy that route from the list

      Expected result: Route deployed

      Actual result: Route deployed, however out of sync appears in the list. After refresh everything's OK.

       

      Attaching a gif of the issue.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cameron.martin Cameron Martin
                Reporter:
                jan.hajovsky Jan Hajovsky
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: