Uploaded image for project: 'Identity Gateway'
  1. Identity Gateway
  2. OPENIG-4828

ClientHandler does not support HTTP/2 upgrade (with IG Standalone)

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 7.0.0, 7.0.0-micsvc-1.0.3
    • Fix Version/s: 7.0.0, 7.0.0-micsvc-1.0.3
    • Component/s: Core, Doc
    • Labels:
      None
    • Sprint:
      2020.10 - IG / Microservices, 2020.11 - IG / Microservices
    • Story Points:
      1

      Description

      Problem unearthed during testing of OPENIG-4531.

      See: PR comment (with test instruction).

      The strange thing is that this test works when applied to a ReverseProxyHandler but does not when applied to a ClientHandler. Noted that there are additional filters inserted when using the ReverseProxyHandler. Note also that the ClientHandler supports this request as plain HTTP/1.1 and HTTP/2 with HTTPS, but does not seem to manage this as an upgrade.

      Unclear if this is a bug - or a docs issue. That is, it may be a docs issue if the ClientHandler does not support HTTP2 upgrade when used with IG Standalone.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                wayne.morrison Wayne Morrison
                Reporter:
                wayne.morrison Wayne Morrison
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: