Uploaded image for project: 'OpenAM'
  1. OpenAM
  2. OPENAM-6928

Audit log doesn't contain user name, only "user (empty)" when there is no policy or access is denied by policy

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Agents-4.0.0
    • Fix Version/s: Agents-4.0.0, Agents-5.0
    • Component/s: web agents
    • Labels:
    • Environment:
      Tested on WPA for Windows and Linux
    • Sprint:
      Sprint 95 - Team Curie, Sprint 97 - Team Curie

      Description

      • Audit logging is turned on in LOG_BOTH or LOG_DENY
      • User attempts to access resource with no policy or the user is denied to access by existing policy
        • expectation: there is the user name in audit log
        • actual: there is only "user (empty) "
          2015-09-23 16:20:27.519 +0100 AUDIT [0x7f3193fff700:28734] user (empty) (172.18.1.1) was denied access to https://FQDN:443/index.html

      When access to resource is allowed (and audit logging is LOG_ALLOW or LOG_BOTH), the user name is logged correctly.

        Attachments

          Activity

            People

            • Assignee:
              spareyc Charles Sparey
              Reporter:
              tomas.hejret Tomas Hejret
              QA Assignee:
              Tomas Hejret
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: