Uploaded image for project: 'Commons Self Service'
  1. Commons Self Service
  2. USS-121

Enhancement for UserQuery stage to set Resource Version

    XMLWordPrintable

    Details

    • Improvement
    • Status: Done
    • Major
    • Resolution: Done
    • 20.0.0
    • 23.0.0

      Description

      This RFE is linked to OPENAM-11678
      Enhancement for UserQuery stage to set Resource Version

      How to reproduce the issue
      1. configure OpenAM 13.5.0 (or upgrade to OpenAM 13.5.0 from OpenAM 12)
      2. configure selfservice password reset, choose to send email
      3. configure Email service
      4. if not upgraded from 12.x, configure global REST API version to 'Oldest'
        (ssoadm set-attr-defs -u amadmin -f PATH_TO_PWDFILE -s RestApisService -t global -a openam-rest-apis-default-version=Oldest)
      5. perform REST base password reset for a valid user
        curl -X POST -H 'Content-Type: application/json' -H 'Accept-Language: en-US,de' --data '{"input":{"queryFilter":"uid eq \"demo\""}}' 'http://openam1350.test.xyz:8080/openam/json/selfservice/forgottenPassword?_action=submitRequirements'
      Expected behaviour
      Password rest email should be send
      
      Current behaviour
      REST call fails with
      {"code":400,"reason":"Bad Request","message":"Unable to find account"}
      

        Attachments

          Issue Links

            Activity

              People

              sachiko Sachiko Wallace
              sachiko Sachiko Wallace
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: