[AMAGENTS-1933] init_ssl errors fill error_log Created: 07/Sep/18  Updated: 26/Nov/18  Resolved: 15/Nov/18

Status: Closed
Project: OpenAM Agents
Component/s: Web Agents
Affects Version/s: 5.5.0.0
Fix Version/s: 5.5.1.0

Type: Bug Priority: Major
Reporter: Alex Levin Assignee: Mareks Malnacs
Resolution: Fixed Votes: 0
Labels: DIRAC
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Target Version/s:
Verified Version/s:

 Description   

Bug description

init_ssl errors (that are more warnings) are filling the logs on 5.5.0-RC2

How to reproduce the issue

  1. Startup agent
  2. Look at logs
Expected behaviour
Succinct logging eg 1 line which per process which says that a) overall whether an openssl library was loadable and ideally it's name version b) what versions were found c) if no versions were found then we would be interested in the library names
Current behaviour
Per process each will loop through the list of openssl variants.
Fri Sep 07 08:41:18.054507 2018] [amagent:error] [pid 14995:tid 140653367654208] init_ssl(): trying libssl...
[Fri Sep 07 08:41:18.055120 2018] [amagent:error] [pid 14995:tid 140653367654208] init_ssl(): libssl.so.1.1 dlopen error: libssl.so.1.1: cannot open shared object file: No such file or directory
[Fri Sep 07 08:41:18.055227 2018] [amagent:error] [pid 14995:tid 140653367654208] init_ssl(): libssl.so.10 dlopen error: libssl.so.10: cannot open shared object file: No such file or directory
[Fri Sep 07 08:41:18.055313 2018] [amagent:error] [pid 14995:tid 140653367654208] init_ssl(): libssl.so.1.0.2 dlopen error: libssl.so.1.0.2: cannot open shared object file: No such file or directory
[Fri Sep 07 08:41:18.055395 2018] [amagent:error] [pid 14995:tid 140653367654208] init_ssl(): libssl.so.1.0.1 dlopen error: libssl.so.1.0.1: cannot open shared object file: No such file or directory
[Fri Sep 07 08:41:18.056391 2018] [amagent:error] [pid 14995:tid 140653367654208] init_ssl(): found libssl.so.1.0.0
[Fri Sep 07 08:41:18.056471 2018] [amagent:error] [pid 14995:tid 140653367654208] init_ssl(): failed to load OPENSSL_init_ssl

This is instant ticket creation territory.

Work around

Cannot be changed to a different level.

Code analysis

OPTIONAL - If you already investigated the code, please share your finding here (remove this text)

org.forgerock.$className.java
...


 Comments   
Comment by Ľubomír Mlích [ 12/Nov/18 ]

Verified as fixed as in Agents 5.5.0.1-M1 there is one line in install log, regarding SSL comparing to more lines in 5.5.0.0

Comment by Ľubomír Mlích [ 15/Nov/18 ]

Reopened by mistake, sorry.

Generated at Sun Sep 27 19:42:00 UTC 2020 using Jira 7.13.12#713012-sha1:6e07c38070d5191bbf7353952ed38f111754533a.