[AMAGENTS-2716] Remove init_ssl(): failed to load OPENSSL_init_ssl message in apache error_log Created: 30/May/19  Updated: 13/Aug/19

Status: Open
Project: OpenAM Agents
Component/s: Web Agents
Affects Version/s: None
Fix Version/s: None

Type: Bug Priority: Minor
Reporter: Abel Hoxeng Assignee: Unassigned
Resolution: Unresolved Votes: 0
Labels: CURIE, DIRAC
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Support Ticket IDs:

 Description   

Currently error logging in the agent writes the following to the log:

 

[Thu May 23 15:28:52.670107 2019] [amagent:error] [pid 693:tid 139898957121792] init_ssl(): failed to load OPENSSL_init_ssl

[Thu May 23 15:28:52.670135 2019] [amagent:error] [pid 693:tid 139898957121792] init_ssl(): failed to load TLS_client_method

[Thu May 23 15:28:52.670142 2019] [amagent:error] [pid 693:tid 139898957121792] init_ssl(): failed to load SSL_get_state

[Thu May 23 15:28:52.670214 2019] [amagent:error] [pid 693:tid 139898957121792] init_ssl(): trying libcrypto...

[Thu May 23 15:28:52.670437 2019] [amagent:error] [pid 693:tid 139898957121792] init_ssl(): libcrypto.so.1.1 dlopen error: libcrypto.so.1.1: cannot open shared object file: No such file or directory

[Thu May 23 15:28:52.670551 2019] [amagent:error] [pid 693:tid 139898957121792] init_ssl(): found libcrypto.so.10

[Thu May 23 15:28:52.670974 2019] [amagent:error] [pid 693:tid 139898957121792] init_ssl(): OpenSSL v1.0.x/0.9.8 library support is available

But this is not actually an error, but is a message logged by the agent during OpenSSL library/symbols lookup. This should be shown is message mode to prevent confusion for end users looking at the error mode logs


Generated at Mon Sep 21 15:24:41 UTC 2020 using Jira 7.13.12#713012-sha1:6e07c38070d5191bbf7353952ed38f111754533a.