[OPENAM-11737] http.response.headers not populating in audit logs Created: 12/Sep/17  Updated: 25/Jun/20

Status: Open
Project: OpenAM
Component/s: audit logging
Affects Version/s: 13.5.1, 14.5.0, 7.0.0
Fix Version/s: None

Type: Bug Priority: Major
Reporter: Sam Fraser Assignee: Unassigned
Resolution: Unresolved Votes: 0
Labels: AME, FRAAS, audit
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Duplicate
duplicates OPENAM-16388 AM audit logs should log response hea... Closed
Relates
Target Version/s:
Support Ticket IDs:

 Description   

Bug description

No audit logging appears for http.response.headers

How to reproduce the issue

Use REST to generate a JSON response.  REST requests returns json formatted data which should contain a header of the form, 'Content-type: application/json'

  1. Make sure audit logging is enabled
  2. Make a REST call to an endpoint to get a JSON response
  3. Check the audit logs for a value in the http.response.headers field of the corresponding entry.
Expected behaviour
http.response.headers should have at least 'Content-type: application/json'as a Response Header
Current behaviour
http.response.headers is blank

 



 Comments   
Comment by Andrew Vinall [ 13/Sep/17 ]

Bug Triage: Sam Fraser Is there a customer ticket we can attach to this bug?

Comment by Sam Fraser [ 13/Sep/17 ]

Oops. missed that

 

Comment by Sam Fraser [ 15/Sep/17 ]

Customer asked me to note that while my use case is specific to REST calls, it appears that no logging of Response Headers takes place in the audit logs for any parts of the AM codebase.

Comment by Andy Hall [ 22/Jun/20 ]

Too late for 7.0

Generated at Sun Sep 27 22:43:53 UTC 2020 using Jira 7.13.12#713012-sha1:6e07c38070d5191bbf7353952ed38f111754533a.