[OPENAM-11834] Passwords being set to empty strings in tabbed forms in XUI Created: 25/Sep/17  Updated: 22/Jan/18  Resolved: 05/Oct/17

Status: Closed
Project: OpenAM
Component/s: XUI
Affects Version/s: 13.5.1, 14.0.0, 14.1.1, 14.5.0
Fix Version/s: 13.5.2, 14.5.0

Type: Bug Priority: Major
Reporter: Julian Kigwana [X] (Inactive) Assignee: Julian Kigwana [X] (Inactive)
Resolution: Fixed Votes: 0
Labels: AME, Must-Fix, TURING, XUI
Σ Remaining Estimate: Not Specified Remaining Estimate: Not Specified
Σ Time Spent: Not Specified Time Spent: Not Specified
Σ Original Estimate: Not Specified Original Estimate: Not Specified
Environment:

XUI


Attachments: PNG File 13.5.0.png     PNG File 13.5.2-RC1.png    
Issue Links:
Depends
is required by OPENAM-11763 "Saving" CTS configuration overwrites... Closed
Duplicate
is duplicated by OPENAM-11763 "Saving" CTS configuration overwrites... Closed
Regression
is caused by OPENAM-10472 Values are not properly updated when ... Closed
Relates
Sub-Tasks:
Key
Summary
Type
Status
Assignee
OPENAM-12055 Password being set to empty String on... Technical task Closed  
Target Version/s:
Needs backport:
Yes
Support Ticket IDs:
Verified Version/s:
Needs QA verification:
Yes
Functional tests:
No
Are the reproduction steps defined?:
Yes and I used the same an in the description

 Description   
  1. Goto the Oauth2 clients view
  2. On the first tab change any property except the password and press save
  3. Go to another tab and press save
Expected behaviour:

The form to save the properties properly

Current behaviour

A validation error from the server, because the password in the previous tab has been changed to an empty string!

Code analysis

This behaviour was introduced while resolving OPENAM-10472 and will potentially effect all tabbed jsoneditor forms that have passwords.



 Comments   
Comment by Julian Kigwana [X] (Inactive) [ 05/Oct/17 ]

This needs backporting to 14.1.1 and 13.5.1

Comment by Julian Kigwana [X] (Inactive) [ 04/Jan/18 ]

Ľubomír Mlích please take a look at my comment and examples on the PR, https://stash.forgerock.org/projects/OPENAM/repos/openam-sustaining/pull-requests/1227/overview?commentId=267781

Comment by Ľubomír Mlích [ 22/Jan/18 ]

Julian Kigwana [X] thanks.

Reproduced on OpenAM 13.5.0 Build 550cfe7d60 (2016-July-13 08:43) , that I can see password being replaced on http://amqa-clone70.test.forgerock.com:8080/openam/XUI/#configure/server-defaults/cts while saving CTS Token Store where password is not visible for user.
Verified bug fix on OpenAM 13.5.2-RC1 Build be353da9e6 (2018-January-03 11:17) 

Comment by Ľubomír Mlích [ 22/Jan/18 ]

Nobody will verify in 14.5.0 as this version is already released, closing.

Generated at Tue Dec 01 17:24:00 UTC 2020 using Jira 7.13.12#713012-sha1:6e07c38070d5191bbf7353952ed38f111754533a.