[OPENAM-11906] Amster import using --clean true and site url hangs Created: 04/Oct/17  Updated: 08/Feb/19  Resolved: 08/Feb/19

Status: Closed
Project: OpenAM
Component/s: Amster
Affects Version/s: 14.1.1
Fix Version/s: None

Type: Bug Priority: Major
Reporter: Joe Starling Assignee: Unassigned
Resolution: Won't Fix Votes: 1
Labels: AME, dev-ops
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Relates
is related to OPENAM-11050 Amster: 'import-config --clean true' ... Open
Epic Link: AMster (Phase III)
Support Ticket IDs:

 Description   

Bug description

Connecting to AM through the primary site url and trying to import a config hangs

How to reproduce the issue

  1. Set up AM server
  2. Add server to site
  3. Run LB
  4. use Amster to connect via site url
  5. export-config
  6. import-config
am> connect -i http://lb.example.com:8080/openam
Sign in
User Name: amadmin
Password: **********
amster lb.example.com:8080> export-config --path /home/forgerock/export
Export completed successfully
amster lb.example.com:8080> import-config --path /home/forgerock/export --clean true --failOnError true
Cleaning global settings
Deleting JSON: Global JSON Handler
Deleting Scripting: 9de3eb62-f131-4fac-a294-7bd170fd4acb
Deleting Scripting: 7e3d7067-d50f-4674-8c76-a3e13a810c33
Deleting Scripting: c827d2b4-3608-4693-868e-bbcf86bd87c7
Deleting Scripting: 703dab1a-1921-4981-98dd-b8e5349d8548
Deleting Scripting: 157298c0-7d31-4059-a95b-eeb08473b7e5
Deleting Scripting: 36863ffb-40ec-48b9-94b1-9a99f71cc3b5
Deleting Servers: 01
Deleting Sites: site
                       ++hangs++
Expected behaviour

config is imported, or appropriate error message is shown. 

Current behaviour

command hangs indefinitely

 

 



 Comments   
Comment by James Phillpotts [ 08/Feb/19 ]

Amster needs to connect directly to AM, not via a load balancer.

Generated at Sun Sep 27 23:34:59 UTC 2020 using Jira 7.13.12#713012-sha1:6e07c38070d5191bbf7353952ed38f111754533a.