[OPENAM-12948] Creating realm with inner tree - 400 Error: "Data validation failed for the attribute, Tree Name" Created: 18/Apr/18  Updated: 30/Apr/18  Resolved: 30/Apr/18

Status: Resolved
Project: OpenAM
Component/s: trees
Affects Version/s: 6.0.0
Fix Version/s: 6.0.0

Type: Bug Priority: Major
Reporter: Andrew Vinall Assignee: Gabor Melkvi
Resolution: Fixed Votes: 0
Labels: AME, Must-Fix
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

ForgeRock Access Management 6.0.0-SNAPSHOT Build 28ad874390 (2018-April-17 23:37)


Issue Links:
Relates
is related to OPENAM-12901 Webhooks and trees fail to clone to s... Resolved
Target Version/s:
Needs backport:
No
Needs QA verification:
No
Functional tests:
Yes
Are the reproduction steps defined?:
Yes and I used the same an in the description

 Description   

Bug description

Creating realm with inner tree - 400 Error: "Data validation failed for the attribute, Tree Name"

How to reproduce the issue

  • Create an Inner Tree
  • Create a sub realm
Expected behaviour

Realm created without error

Current behaviour
{"code":400,"reason":"Bad Request","message":"Data validation failed for the attribute, Tree Name"}

Trees aren't cloned to the subrealm



 Comments   
Comment by James Phillpotts [ 19/Apr/18 ]

AM Triage: This sounds an awful lot like something that Michael Carter and Gabor Melkvi have been working on recently

Generated at Tue Nov 24 06:21:29 UTC 2020 using Jira 7.13.12#713012-sha1:6e07c38070d5191bbf7353952ed38f111754533a.