[OPENAM-14569] XUI Switch realm not working with login fragment Created: 08/Mar/19  Updated: 04/Apr/19  Resolved: 04/Apr/19

Status: Closed
Project: OpenAM
Component/s: XUI
Affects Version/s: 7.0.0
Fix Version/s: 7.0.0

Type: Bug Priority: Major
Reporter: Julian Kigwana [X] (Inactive) Assignee: Julian Kigwana [X] (Inactive)
Resolution: Fixed Votes: 1
Labels: AME, Must-Fix, TURING, XUI
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Attachments: File switch-realm.mp4    
Issue Links:
Duplicate
is duplicated by OPENAM-13905 XUI Authentication - Switching realms... Resolved
Regression
is caused by OPENAM-14483 If there is no token, then landing on... Closed
Target Version/s:
Rank: 1|hzk1pr:
Sprint: 2019.4 - Coins, 2019.5 - Scissors

 Description   

switch-realm.mp4

Bug description

Error "Session Upgrade fails since user is different than original authenticated user" displayed after switching realms and trying to re-authenticate

How to reproduce the issue

  1. Create a subrealm and login to it with demo
  2. Change the url to `/XUI/?realm=/#login/`
  3. On the switch-realm page, press Yes - Log into new site
  4. Try to log into the new site
Expected behaviour
Can log into AM
Current behaviour
Error message saying "Session Upgrade fails since user is different than original authenticated user"

Work around

Works 2nd time



 Comments   
Comment by Julian Kigwana [X] (Inactive) [ 11/Mar/19 ]

Just checked and this bug existed before the split of the ui

Generated at Sat Mar 06 02:02:18 UTC 2021 using Jira 7.13.12#713012-sha1:6e07c38070d5191bbf7353952ed38f111754533a.