[OPENAM-14878] Configuring a second AM server using the configurator-tool.jar does not create the needed secrets/encrypted folder Created: 03/May/19  Updated: 13/May/19  Resolved: 13/May/19

Status: Closed
Project: OpenAM
Component/s: configurator
Affects Version/s: 6.5.1
Fix Version/s: None

Type: Bug Priority: Major
Reporter: Tom Jones Assignee: Unassigned
Resolution: Duplicate Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

AM 6.5.1 w/ external config store


Issue Links:
Duplicate
duplicates OPENAM-14163 Secret stores are not created during ... Resolved
Rank: 1|hzy6s7:
Support Ticket IDs:

 Description   

Bug description

Adding another AM server to an existing installation using an external config store, using the configurator-tool.jar "silent install" method, fails to create the needed secrets/encrypted folder. This folder contains the entrypass and storepass files. This was fixed for the install wizard and amster methods in https://bugster.forgerock.org/jira/browse/OPENAM-14163 it appears it wasn't fixed in the configurator tool method.

 

How to reproduce the issue
- Install an AM 6.5.1 using an external configuration store

  • On another vm install another AM 6.5.1 using the configurator-tool.jar 
    make sure you obtain the AM_ENC_KEY from the first AM installation, you will need it.
    Use the attached config.properties as a guide 
  • Notice that <AM home>/secrets/encrypted folder does not exist on the second server and that you can not login to the second server.

 

Expected behaviour
secrets/encrypted folder is created with the proper files on the second server
Current behaviour
secrets/encrypted folder does not exist on the second server

Work around

OPTIONAL - If you have a workaround, please put the details here (remove this text)

Code analysis

OPTIONAL - If you already investigated the code, please share your finding here (remove this text)

org.forgerock.$className.java
...


 Comments   
Comment by Andrew Vinall [ 13/May/19 ]

Bug Triage: OPENAM-14163 did not contain a fix but provided documentation.

Generated at Thu Feb 25 16:20:30 UTC 2021 using Jira 7.13.12#713012-sha1:6e07c38070d5191bbf7353952ed38f111754533a.