[OPENAM-15821] AM fails during embedded replication setup when adding a new node to existing deployment Created: 07/Jan/20  Updated: 19/Jun/20  Resolved: 18/Jun/20

Status: Resolved
Project: OpenAM
Component/s: configurator
Affects Version/s: 7.0.0
Fix Version/s: None

Type: Bug Priority: Critical
Reporter: Peter Major [X] (Inactive) Assignee: Unassigned
Resolution: Won't Do Votes: 0
Labels: AME, Must-FIx
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Depends
is required by OPENDJ-6624 Remove code of (old) dsreplication tool Done
Duplicate
Relates
Target Version/s:
Rank: 1|hzzq7z:

 Description   

Bug description

When one attempts to set up an AM environment with multiple AM nodes using the embedded configuration store, the setup of the second AM instance fails.

How to reproduce the issue

  • Set up first AM instance using embedded
  • Try to add second AM instance to existing deployment
Expected behaviour

Setup successfully completes

Current behaviour

Setup fails to establish replication between the embedded instances

Code analysis

The suggestion from the DS team was that the DS nodes need to share the same deployment key in order to be able to replicate with each other. This means that the first AM node's deployment key needs to be saved somewhere, and most likely we'll need to update getServerInfo.jsp to make it available for the second AM instance.

Alternatively the embedded DS's deployment key could be a secret that needs to be made available before installation.



 Comments   
Comment by Phill Cunnington [ 18/Jun/20 ]

Embedded DS in 7.0 is explicitly stated as not supported in production so replication does not need to be used as this is a feature to be configured for a production DS instances.

Comment by Peter Major [X] (Inactive) [ 18/Jun/20 ]

Should we update the wizard and the command line install tools to this effect then?

Comment by Matthew Swift [ 18/Jun/20 ]

CC/ Jean-Noël Rouvignac

Comment by Phill Cunnington [ 18/Jun/20 ]

Yes we should update wizard to state that embedded DS is not supported for production use.

Generated at Mon Mar 01 10:05:34 UTC 2021 using Jira 7.13.12#713012-sha1:6e07c38070d5191bbf7353952ed38f111754533a.