[OPENAM-16152] After upgrade, new Identity page has duplicate 'new identity' field and email address does not save Created: 22/Apr/20  Updated: 05/Nov/20  Resolved: 24/Aug/20

Status: Resolved
Project: OpenAM
Component/s: upgrade
Affects Version/s: 6.5.2.3, 7.0.0, 6.5.3
Fix Version/s: 6.5.3, 7.1.0, 7.0.1

Type: Bug Priority: Blocker
Reporter: Lawrence Yarham Assignee: Michael Carter
Resolution: Fixed Votes: 0
Labels: AME, IAM, Must-FIx, Newton, release-notes
Σ Remaining Estimate: Not Specified Remaining Estimate: Not Specified
Σ Time Spent: Not Specified Time Spent: Not Specified
Σ Original Estimate: Not Specified Original Estimate: Not Specified

Attachments: PNG File Screen Shot 2020-04-21 at 4.57.02 PM.png    
Issue Links:
Duplicate
is duplicated by OPENAM-17025 after AM upgrade from 5.5.2 with exte... Closed
Sub-Tasks:
Key
Summary
Type
Status
Assignee
OPENAM-16670 Identify reason for optional fields b... Technical task Closed Michael Carter  
OPENAM-16671 Identify cause of duplicate UID inputs Technical task Closed Michael Carter  
OPENAM-16680 Attempt a unit test for IdentityResou... Technical task Closed Michael Carter  
Target Version/s:
Sprint: AM 2020.11 - Trip Hammer
Epic Link: 7.0.0 Post-Release

 Description   

After an upgrade from 6.0.0.7, the Identities -> New Identity page is displaying more fields that previously, has two 'User ID' fields, and specifying an email address does not result in it being saved when the identity is created.

 

Reproduction steps:

  1. AM deployment 6.0.0.7, embedded config and user store.
  2. Upgrade to AM 7.0.0 snapshot war.
  3. Login as amadmin.  Navigate to top level realm, Identities.
  4. Click to Add new identity.
  5. Observe the fields present on the page.  Previously there were fewer fields on the create page (user id, password and email address if I remember correctly) - not sure if addition of more is intentional here or not.
  6.  Fill out the fields on the page (I tested email address, both user id fields and password).  Save to create the identity.
  7. On the edit identity displayed back, the email address is blank.  I've not tested other fields to see if these have saved as expected or not.


 Comments   
Comment by Andrew Vinall [ 22/Apr/20 ]

Lawrence Yarham Was this an upgrade or clean install?

Comment by Craig Gering [ 21/Jul/20 ]

waiting for verification that this is problem on backend due to upgrade & not ui specific problem

Comment by Michael Carter [ 13/Aug/20 ]

Both Dipu Seminlal and I were unable to recreate this going from 6.5.0 > 7.x.0. It seems to only affect upgrades from 6.0.0.7.

Comment by Adam Heath [ 24/Aug/20 ]

Re-opening to transition issue status to "Resolved". Please can JIRAs be marked as "Resolved" rather than "Closed" when complete, especially when impacting older versions as well, as otherwise the JIRA can no longer be edited to update target/fix versions when backporting issues.

Generated at Fri Dec 04 11:23:02 UTC 2020 using Jira 7.13.12#713012-sha1:6e07c38070d5191bbf7353952ed38f111754533a.