[OPENAM-5381] Specifying an external user store when using configurator tool is not being processed correctly Created: 24/Dec/14  Updated: 25/May/18  Resolved: 12/Jan/15

Status: Resolved
Project: OpenAM
Component/s: configurator, install
Affects Version/s: 12.0.0, 13.0.0
Fix Version/s: 12.0.1, 13.0.0

Type: Bug Priority: Major
Reporter: Mark de Reeper Assignee: Mark de Reeper
Resolution: Fixed Votes: 0
Labels: regression, release-notes
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Duplicate
is duplicated by OPENAM-5397 Unable to Install OpenAM 12.0.0 using... Resolved
is duplicated by OPENAM-5597 Cannot configure external OpenDJ with... Resolved
Support Ticket IDs:
Verified Version/s:

 Description   

The AMSetupServlet uses USERSTORE_TYPE in the POSTed parameters to indicate that an external user store is to be used. When configuring OpenAM via the configurator tool, the USERSTORE_TYPE is removed before the configuration values are POSTed which can lead to the incorrect setup of the external user store or a complete failure of the install if the user store is using LDAPS.

This is a regression as a result of AME-2898 / AME-2894.



 Comments   
Comment by Mark de Reeper [ 12/Jan/15 ]

Fixed in r12040 and r12041.

Comment by Nemanja Lukic [ 14/Jul/15 ]

Verified in: OpenAM 12.0.1 Build 14322 (2015-June-22 16:03)

Comment by David Hanlon [X] (Inactive) [ 03/Jan/17 ]

This is issue still appears in version 13.

Comment by Mark de Reeper [ 03/Jan/17 ]

David Hanlon [X] Please provide the reproduction steps and any debug/install logs so we can investigate.

Generated at Sat Oct 24 00:58:35 UTC 2020 using Jira 7.13.12#713012-sha1:6e07c38070d5191bbf7353952ed38f111754533a.