[OPENAM-6977] Validate OIDC script returns "No privilege mapping for requested action validate" Created: 2015-09-29  Updated: 2015-12-15  Resolved: 2015-09-30

Status: Resolved
Project: OpenAM
Component/s: OpenID Connect
Affects Version/s: 13.0.0
Fix Version/s: 13.0.0

Type: Bug Priority: Major
Reporter: hadi hahmadi [X] (Inactive) Assignee: James Phillpotts
Resolution: Fixed Votes: 0
Labels: 13.0.0-Must-Fix, AME, TESLA, release-notes
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

EC2 Ubuntu 64 VM, Tomcat 7, JDK 1.7, OpenAM 13.0.0-SNAPSHOT Build ${svn-revision.revision} (2015-September-28 15:34)


Attachments: PNG File noPrivilege.png    
Issue Links:
Duplicate
duplicates OPENAM-6958 Script Editor: Attempting to validate... Closed
duplicates OPENAM-6966 Script validation endpoint no longer ... Closed
is duplicated by OPENAM-6964 Script Editor: Validating a script re... Closed
Relates
is related to OPENAM-6958 Script Editor: Attempting to validate... Closed
is related to OPENAM-6964 Script Editor: Validating a script re... Closed
Target Version/s:
Rank: 1|hzljtr:
Sprint: Sprint 95 - Team Tesla

 Description   

Created OAuth2 provider, clicked on "Edit" button below the "OIDC Claims Script". Next, clicked on "Validate": observed the error message:
"No privilege mapping for requested action validate"
and was kicked of the session.

I believe this is somehow the cause for not being able to create an OAuth2 Provider service through SSOADM when a OIDC claims script is appended.



 Comments   
Comment by James Phillpotts [ 2015-09-30 ]

The validate action is now bound to the read privilege.

Generated at Wed Dec 01 06:59:29 UTC 2021 using Jira 8.20.1#820001-sha1:6d4b94dbcc29d26a5651b231dd69e39cd4357315.