[OPENAM-7523] Can't create realm in Internet Explorer 11 Created: 23/Nov/15  Updated: 25/May/18  Resolved: 27/Jan/17

Status: Resolved
Project: OpenAM
Component/s: XUI
Affects Version/s: 13.0.0, 13.5.0
Fix Version/s: 13.0.0, 13.5.2, 14.0.0

Type: Bug Priority: Major
Reporter: Simon Harding Assignee: Joe Starling
Resolution: Fixed Votes: 0
Labels: AME, Should-Fix, TURING
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Client: Windows 2012R2, Internet Explorer 11 (11.0.9600.17031) with enhanced security configuration (ESC) disabled, popup blocker turned off.
Server: Windows 2012R2, Tomcat 8 Java 8.


Attachments: PNG File Fullscreen_23_11_2015__20_55.png     PNG File IE11 and Edge.png     PNG File Screen Shot 2017-11-14 at 5.52.00 PM.png     PNG File screenshot-1.png    
Issue Links:
Duplicate
is duplicated by OPENAM-7843 Script Module settings does not appea... Closed
Relates
relates to OPENAM-11706 Policies in a policy set are not visi... In Review
is related to OPENAM-10522 Can't create authentication module in... Closed
is related to OPENAM-7843 Script Module settings does not appea... Closed
Target Version/s:
Sprint: Sprint 100 - Team Newton, Sprint 120 "Aivazovsky" Turing
Support Ticket IDs:
QA Assignee: Joanna Wasilewska [X] (Inactive)
Verified Version/s:

 Description   

1. Deployed OpenAM-13.0.0-SNAPSHOT_20151120.war on a Windows Server 2012R2 VM running Tomcat.
2. Setup AM with default configuration.
3. Login to OpenAM as amadmin on same VM using IE11, selected realms from the top bar, then "+ new realm".

result: nothing, no create realm dialogue appears.
expected result: create realm dialogue appears.

Work around: It works as expected in google chrome 46 on same environment.

Not found an existing bug on this, my apologies if it has already been picked up.



 Comments   
Comment by Andy Hall [ 23/Nov/15 ]

I found this hard to believe so installed Windows 10 to test and Simon Harding is correct.
Creating a new realm will throw an error in the Microsoft Edge browser as in the attached screenshot.

Comment by Andy Hall [ 14/Dec/15 ]

Looks awfully similar

Comment by Sam Phua [ 27/Jan/17 ]

The issue is due to this

SCRIPT5007: Object.freeze: argument is not an Object
JSONValues.js, line 93 character 13

Can we use this as a workaround in the JSONValues.js ?

// this.raw = Object.freeze(values);
this.raw = values ;

Comment by Ľubomír Mlích [ 31/Jul/17 ]

Verified in OpenAM 13.5.2-M3 Build 793c97364a (2017-July-28 13:02) 

Comment by Jobby Thomas [ 14/Nov/17 ]

I am able to reproduce in my environment...I can't create a new realm in IE

Please see screenshot attached

Generated at Fri Oct 23 10:42:20 UTC 2020 using Jira 7.13.12#713012-sha1:6e07c38070d5191bbf7353952ed38f111754533a.