[OPENAM-8486] WPA interactive installator can't correctly read provided Apache configuration path Created: 04/Mar/16  Updated: 02/Dec/16  Resolved: 02/Dec/16

Status: Closed
Project: OpenAM
Component/s: install, web agents
Affects Version/s: Agents-4.0.1
Fix Version/s: Agents-4.1.0, Agents-5.0

Type: Bug Priority: Major
Reporter: Tomas Hejret Assignee: Mareks Malnacs
Resolution: Fixed Votes: 0
Labels: AMAgent, AME, implementation-bug
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Ubuntu12.04 64bit

OpenAM Web Agent for Apache Server 2.2.x
Version: 4.0.1-RC2
Revision: 5b3b9c4
Build machine: delacroix
Build date: Feb 23 2016 11:31:22


Issue Links:
Relates
is related to OPENAM-8406 Agent 4.0.0 can not process the defau... Closed
Epic Link: Web Agent 4.1.0 Release
Support Ticket IDs:
QA Assignee: Tomas Hejret
Verified Version/s:

 Description   

Provided:

/etc/apache2/httpd.conf

Expected continue to next step as was verified that file really exists.
Observed:

Error: unable to load the server configuration file /etc/apache2/httpd.conf.]

Provided (missing "f" in ".conf"):

/etc/apache2/httpd.con

Expected continue to next step as was verified that file really exists.
Observed (missing bracket "]" at the end of output):

Error: unable to load the server configuration file/etc/apache2/httpd.con.

If the file path is incorrect there is missing bracket "]" at the end of output.
Silent installation works as expected.



 Comments   
Comment by Mareks Malnacs [ 07/Mar/16 ]

What is in output of the following command?

echo $TERM

Comment by Tomas Hejret [ 10/Mar/16 ]
# echo $TERM
xterm
Comment by Richard Hruza [ 21/Oct/16 ]

Verified and closed. Was not tested with WPA 5.0, because WPA 4.1. and WPA 5.0 has identical code.

The issue is possible to reproduce when is used default apache for ubuntu (see linked bug for more details).

WPA 4.0.1 Response
Error: invalid server configuration file /etc/apache2/apache2.conf.]
Please try again.

Enter the complete path to the httpd.conf file which is used by Apache HTTP
Server to store its configuration.
[ q or 'ctrl+c' to exit ]
Configuration file [/opt/apache/conf/httpd.conf]:
WPA 4.1.0 Response
Warning: Apache HTTP Server configuration file /etc/apache2/apache2.conf does not contain any "LoadModule" directive.
Updating this file may result in corrupt Apache HTTP Server installation and Agent failure.

Do you want to continue?
[ q or 'ctrl+c' to exit ]
(yes/no): [no]: 

Verified

OpenAM Web Agent for Apache Server 2.4.x
 Version: 4.1.0-RC2
 Revision: 05a5203
 Build machine: delacroix
 Build date: Oct 17 2016 14:42:10

Reproduced

OpenAM Web Agent for Apache Server 2.4.x
 Version: 4.0.1
 Revision: 1602ea1
 Build machine: delacroix
 Build date: Apr  7 2016 11:25:58
Comment by Quentin CASTEL [X] (Inactive) [ 20/Nov/16 ]

modification of the status, in order to migrate the 'Zendesk ID' field to 'Support Ticket ID' field.

Comment by Quentin CASTEL [X] (Inactive) [ 20/Nov/16 ]

modification of the status, in order to migrate the 'Zendesk ID' field to 'Support Ticket ID' field.

Generated at Sat Sep 26 00:29:02 UTC 2020 using Jira 7.13.12#713012-sha1:6e07c38070d5191bbf7353952ed38f111754533a.