[OPENAM-9652] cookie domain not set correctly Created: 05/Sep/16  Updated: 06/Sep/16  Resolved: 06/Sep/16

Status: Resolved
Project: OpenAM
Component/s: configurator
Affects Version/s: 13.5.0
Fix Version/s: None

Type: Bug Priority: Critical
Reporter: Bernhard Thalmayr Assignee: Peter Major [X] (Inactive)
Resolution: Cannot Reproduce Votes: 0
Labels: Backlog
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Mac OS X

java version "1.8.0_31"
Java(TM) SE Runtime Environment (build 1.8.0_31-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.31-b07, mixed mode)

Apace Tomcat 8.5.4

OpenAM 13.5.0


Issue Links:
Relates
is related to OPENAM-9650 OpenAM unusable when removing cookie ... Resolved
Rank: 1|hzs2dj:

 Description   

OpenAM GUI configurator allows to configure host-based cookies by removing the value from the cookie domain field. However after initial configuration the cookie domain is not correctly set as the following output of ssoadm reveals.

./ssoadm get-attr-defs -s iPlanetAMPlatformService -t global -u amadmin -f ~/.am.pwd

serviceObjectClasses=iplanet-am-platform-service
iplanet-am-platform-cookie-domains=openam1350.test.xyz
iplanet-am-platform-locale=en_US

Schema attribute defaults were returned.


 Comments   
Comment by Sam Drew [ 06/Sep/16 ]

Workaround: Go into the console after configuration and delete cookie domain.

Comment by Peter Major [X] (Inactive) [ 06/Sep/16 ]

Just installed OpenAM with an empty cookie domain value using the GUI configurator, and the configuration value was empty as expected.

Generated at Thu Feb 25 16:42:10 UTC 2021 using Jira 7.13.12#713012-sha1:6e07c38070d5191bbf7353952ed38f111754533a.